Can't rate a game or change it's shelf

Whenever I press a rating or shelf it just scrolls to the top of the window and doesn’t do anything. Issue has been going on for a month on whatever browser I use. Anyone facing the same problem?

I’ve not had issues. Does it happen everywhere on the site where you can add ratings? (Like the news feed for example). What OS and Browsers have you tried?

Like @Inc said, what browsers have you tried? Do you have JavaScript enabled? That’s more or less what’s happening is that the JavaScript isn’t loading in properly and clicking on buttons is just clicking links that take you to # on the page.

Just out of curiousity, can you see what brings up in your browser?

Thanks for responding. I’m using mac os sierra. I’ve tried Safari and Chrome and have made sure javascript is enabled. The link you gave also doesn’t work on them saying server not found.

Ok, if that link doesn’t work, then something is blocking jquery from loading. Are you running an adblocker or pi hole, or some kind of DNS filtering service?

Not that i’m aware of but yes the problem is my wifi as it works when using VPN. So thanks for the help Ill check into that.