Import is not working for me

It’s been months since a game was imported in my steam shelf. However I have got some new games all this time.

Can you look into it?


I just looked at it. The URL you had in our system was the Steam URL with your Steam ID in it. It’s a long story, but my import code currently looks at the URL you have in our system, takes the last part of it (which would have been the big long number in your case) and asks Steam what is this user’s Steam based on the vanity URL name I’m giving you. In a normal circumstance, it would look at the username I gave it, for example my username is pcorsaro, and it would return the big long number that is the Steam user ID associated with the account. Since yours already was the Steam user ID, which is a perfectly valid URL btw, Steam returns nothing for your Steam ID.

Basically what I’m saying is using the URL with your Steam ID in it doesn’t work the way it’s currently setup. I changed your Steam URL in our Steam to use your vanity URL, and it should work tonight. I’ll keep an eye on it and see if it doesn’t work.

You can also cheat and kick the import off early if you’d like. Go to your settings page (Log In and track your game collection and backlog with Grouvee), delete the Steam URL from your profile, save your profile, re-enter the URL into your profile, then save it again. That’ll kick off a fresh Steam import. Otherwise wait until tonight, and you should get an email.

ok, it works now. However, I really can’t remember. Was vanity ID always used? I am pretty sure I did try to enter it at first (because it’s actually easy to remember) but was reject.

And it use to work fine with the other one too, all summer long.

I also noticed a wrong inmport after last nights update.

My library says I have this Might and Magic VI: The Mandate of Heaven (1998) | Grouvee
but I don’t actually own it.

You used to be able to use either, and I’m hoping to keep it that way. I just have to detect which one a person entered since Steam’s API endpoint I’m using doesn’t like the Steam ID.

You’re right that it would have worked all Summer and stopped working pretty recently. I had to change the way I was doing the import because I was being rate limited using Steam’s XML API. I had to switch over to use their web service API, which is actually way faster, it just works slightly different than the XML API.

I did some digging. Steam says you own app ID 243380. Based on what I can tell, that is Might and Magic VI, which is also known as Might and Magic VI: The Mandate of Heaven. It doesn’t appear to be available on Steam anymore, but you can look here:
You maybe got it through Might & Magic X - Legacy?